// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"%%name%%").unwrap();
let string = "Welcome, %%name%%!
Congratulations!";
let substitution = "\\$1ndy";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}