import re
regex = re.compile(r"%%name%%")
test_str = ("Welcome, %%name%%!\n"
"Congratulations!")
subst = "\\$1ndy"
result = regex.sub(subst, test_str)
if result:
print(result)