$re = '/%%name%%/';
$str = 'Welcome, %%name%%!
Congratulations!';
$subst = "\$1ndy";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;