# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=")(.*?)(?=":)/<span style="color: red;">$1<\/span>/gm;t' <<< "{
\"foo\": \"bar\",
\"age\": 23,
}"