import Foundation
let pattern = #"(?<=")(.*?)(?=":)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"foo": "bar",
"age": 23,
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span style="color: red;">$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)