const regex = /(?<=")(.*?)(?=":)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=")(.*?)(?=":)', 'gm')
const str = `{
"foo": "bar",
"age": 23,
}`;
const subst = `<span style="color: red;">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);