import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\")(.*?)(?=\":)";
final String string = "{\n"
+ " \"foo\": \"bar\",\n"
+ " \"age\": 23,\n"
+ "}";
final String subst = "<span style=\"color: red;\">$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}