re = /(?<=")(.*?)(?=":)/m
str = '{
"foo": "bar",
"age": 23,
}'
subst = '<span style="color: red;">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result