#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=")(.*?)(?=":)"
Local $sString = "{" & @CRLF & _
" "foo": "bar"," & @CRLF & _
" "age": 23," & @CRLF & _
"}"
Local $sSubst = "<span style="color: red;">$1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)