#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)"([^"]*)""
Local $sString = "REQUIREMENT: Match strings between two identical characters" & @CRLF & _
"REGEX FIDDLE: https://regex101.com/r/BVjLuU/2" & @CRLF & _
"" & @CRLF & _
"MATCH:" & @CRLF & _
"A "1" text "+" some more text, and "there can be ==1234== even more "text" & @CRLF & _
"in btw quotes" & @CRLF & _
"" & @CRLF & _
"NO MATCH" & @CRLF & _
"text here, 1234." & @CRLF & _
"" & @CRLF & _
"FURTHER LINKS:" & @CRLF & _
" - Negated character class: https://www.regular-expressions.info/charclass.html#negated" & @CRLF & _
" - Capturing groups: https://www.regular-expressions.info/brackets.html" & @CRLF & _
" - Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970" & @CRLF & _
" - Google for '<language> regex extract part of a match stackoverflow'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")