import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]*)\"";
final String string = "REQUIREMENT: Match strings between two identical characters\n"
+ "REGEX FIDDLE: https://regex101.com/r/BVjLuU/2\n\n"
+ "MATCH:\n"
+ "A \"1\" text \"+\" some more text, and \"there can be ==1234== even more \"text\n"
+ "in btw quotes\n\n"
+ "NO MATCH\n"
+ "text here, 1234.\n\n"
+ "FURTHER LINKS:\n"
+ " - Negated character class: https://www.regular-expressions.info/charclass.html#negated\n"
+ " - Capturing groups: https://www.regular-expressions.info/brackets.html\n"
+ " - Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970\n"
+ " - Google for '<language> regex extract part of a match stackoverflow'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}