# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([^\"]*)\""
test_str = ("REQUIREMENT: Match strings between two identical characters\n"
"REGEX FIDDLE: https://regex101.com/r/BVjLuU/2\n\n"
"MATCH:\n"
"A \"1\" text \"+\" some more text, and \"there can be ==1234== even more \"text\n"
"in btw quotes\n\n"
"NO MATCH\n"
"text here, 1234.\n\n"
"FURTHER LINKS:\n"
" - Negated character class: https://www.regular-expressions.info/charclass.html#negated\n"
" - Capturing groups: https://www.regular-expressions.info/brackets.html\n"
" - Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970\n"
" - Google for '<language> regex extract part of a match stackoverflow'\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.