package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)"([^"]*)"`)
var str = `REQUIREMENT: Match strings between two identical characters
REGEX FIDDLE: https://regex101.com/r/BVjLuU/2
MATCH:
A "1" text "+" some more text, and "there can be ==1234== even more "text
in btw quotes
NO MATCH
text here, 1234.
FURTHER LINKS:
- Negated character class: https://www.regular-expressions.info/charclass.html#negated
- Capturing groups: https://www.regular-expressions.info/brackets.html
- Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970
- Google for '<language> regex extract part of a match stackoverflow'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}