const regex = /"([^"]*)"/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]*)"', 'gi')
const str = `REQUIREMENT: Match strings between two identical characters
REGEX FIDDLE: https://regex101.com/r/BVjLuU/2
MATCH:
A "1" text "+" some more text, and "there can be ==1234== even more "text
in btw quotes
NO MATCH
text here, 1234.
FURTHER LINKS:
- Negated character class: https://www.regular-expressions.info/charclass.html#negated
- Capturing groups: https://www.regular-expressions.info/brackets.html
- Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970
- Google for '<language> regex extract part of a match stackoverflow'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}