re = /"([^"]*)"/i
str = 'REQUIREMENT: Match strings between two identical characters
REGEX FIDDLE: https://regex101.com/r/BVjLuU/2
MATCH:
A "1" text "+" some more text, and "there can be ==1234== even more "text
in btw quotes
NO MATCH
text here, 1234.
FURTHER LINKS:
- Negated character class: https://www.regular-expressions.info/charclass.html#negated
- Capturing groups: https://www.regular-expressions.info/brackets.html
- Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970
- Google for \'<language> regex extract part of a match stackoverflow\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end