using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""]*)""";
string input = @"REQUIREMENT: Match strings between two identical characters
REGEX FIDDLE: https://regex101.com/r/BVjLuU/2
MATCH:
A ""1"" text ""+"" some more text, and ""there can be ==1234== even more ""text
in btw quotes
NO MATCH
text here, 1234.
FURTHER LINKS:
- Negated character class: https://www.regular-expressions.info/charclass.html#negated
- Capturing groups: https://www.regular-expressions.info/brackets.html
- Regex plus vs star difference SO question: https://stackoverflow.com/q/8575281/3832970
- Google for '<language> regex extract part of a match stackoverflow'
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}