#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "wanted\(.*{(.|\n)*}\n{2,}"
Local $sString = "function someFunc() {" & @CRLF & _
" const a = 6;" & @CRLF & _
"" & @CRLF & _
" if (a === 7) {" & @CRLF & _
" while (true) {" & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"wanted()" & @CRLF & _
"" & @CRLF & _
"function wanted() {" & @CRLF & _
" const a = 555;" & @CRLF & _
"" & @CRLF & _
" if (a === 1) {" & @CRLF & _
" while (true) {" & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function someFunc() {" & @CRLF & _
" const a = 6;" & @CRLF & _
"" & @CRLF & _
" if (a === 7) {" & @CRLF & _
" while (true) {" & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")