package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`wanted\(.*{(.|\n)*}\n{2,}`)
var str = `function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}