import Foundation
let pattern = #"wanted\(.*{(.|\n)*}\n{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)