use strict;
my $str = 'function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}';
my $regex = qr/wanted\(.*{(.|\n)*}\n{2,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}