const regex = /wanted\(.*{(.|\n)*}\n{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('wanted\\(.*{(.|\\n)*}\\n{2,}', 'g')
const str = `function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}