re = /wanted\(.*{(.|\n)*}\n{2,}/
str = 'function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end