import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "wanted\\(.*\\{(.|\\n)*\\}\\n{2,}";
final String string = "function someFunc() {\n"
+ " const a = 6;\n\n"
+ " if (a === 7) {\n"
+ " while (true) {\n"
+ " break;\n"
+ " }\n"
+ " }\n"
+ "}\n\n"
+ "wanted()\n\n"
+ "function wanted() {\n"
+ " const a = 555;\n\n"
+ " if (a === 1) {\n"
+ " while (true) {\n"
+ " break;\n"
+ " }\n"
+ " }\n"
+ "}\n\n"
+ "function someFunc() {\n"
+ " const a = 6;\n\n"
+ " if (a === 7) {\n"
+ " while (true) {\n"
+ " break;\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}