# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:0+:){2,}/:/g;t' <<< "2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148"