import Foundation
let pattern = #"\b(?:0+:){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)