// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:0+:){2,}").unwrap();
let string = "2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148";
let substitution = ":";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}