use strict;
my $str = '2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148';
my $regex = qr/\b(?:0+:){2,}/p;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";