re = /\b(?:0+:){2,}/
str = '2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result