const regex = /\b(?:0+:){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:0+:){2,}', 'g')
const str = `2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);