package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:0+:){2,}`)
var str = `2001:db8:0:0:0:0:2:1
fe80:00:00:00:8e3:a11a:2a49:1148`
var substitution = ":"
fmt.Println(re.ReplaceAllString(str, substitution))
}