#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:0+:){2,}"
Local $sString = "2001:db8:0:0:0:0:2:1" & @CRLF & _
"" & @CRLF & _
"fe80:00:00:00:8e3:a11a:2a49:1148"
Local $sSubst = ":"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)