#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*?\/a>"
Local $sString = "<a href="www.something.com">Link</a>" & @CRLF & _
"words before <a href="www.something.com">Link</a>" & @CRLF & _
"<a href="www.something.com">Link</a> words after" & @CRLF & _
"more than one link <a href="www.something.com">Link</a> words <a href="www.something.com">Link</a> jsahd" & @CRLF & _
"<a href="www.something.com">)(YSHUDAKSJKJD<></a><a href="www.something.com">Link</a><a href="www.something.com">Link</a> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")