$re = '/<a.*?\/a>/';
$str = '<a href="www.something.com">Link</a>
words before <a href="www.something.com">Link</a>
<a href="www.something.com">Link</a> words after
more than one link <a href="www.something.com">Link</a> words <a href="www.something.com">Link</a> jsahd
<a href="www.something.com">)(YSHUDAKSJKJD<></a><a href="www.something.com">Link</a><a href="www.something.com">Link</a> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);