package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?\/a>`)
var str = `<a href="www.something.com">Link</a>
words before <a href="www.something.com">Link</a>
<a href="www.something.com">Link</a> words after
more than one link <a href="www.something.com">Link</a> words <a href="www.something.com">Link</a> jsahd
<a href="www.something.com">)(YSHUDAKSJKJD<></a><a href="www.something.com">Link</a><a href="www.something.com">Link</a> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}