using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?\/a>";
string input = @"<a href=""www.something.com"">Link</a>
words before <a href=""www.something.com"">Link</a>
<a href=""www.something.com"">Link</a> words after
more than one link <a href=""www.something.com"">Link</a> words <a href=""www.something.com"">Link</a> jsahd
<a href=""www.something.com"">)(YSHUDAKSJKJD<></a><a href=""www.something.com"">Link</a><a href=""www.something.com"">Link</a> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}