// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a.*?\/a>").unwrap();
let string = "<a href=\"www.something.com\">Link</a>
words before <a href=\"www.something.com\">Link</a>
<a href=\"www.something.com\">Link</a> words after
more than one link <a href=\"www.something.com\">Link</a> words <a href=\"www.something.com\">Link</a> jsahd
<a href=\"www.something.com\">)(YSHUDAKSJKJD<></a><a href=\"www.something.com\">Link</a><a href=\"www.something.com\">Link</a> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}