re = /<a.*?\/a>/
str = '<a href="www.something.com">Link</a>
words before <a href="www.something.com">Link</a>
<a href="www.something.com">Link</a> words after
more than one link <a href="www.something.com">Link</a> words <a href="www.something.com">Link</a> jsahd
<a href="www.something.com">)(YSHUDAKSJKJD<></a><a href="www.something.com">Link</a><a href="www.something.com">Link</a> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end