import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?\\/a>";
final String string = "<a href=\"www.something.com\">Link</a>\n"
+ "words before <a href=\"www.something.com\">Link</a>\n"
+ "<a href=\"www.something.com\">Link</a> words after\n"
+ "more than one link <a href=\"www.something.com\">Link</a> words <a href=\"www.something.com\">Link</a> jsahd\n"
+ "<a href=\"www.something.com\">)(YSHUDAKSJKJD<></a><a href=\"www.something.com\">Link</a><a href=\"www.something.com\">Link</a> ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}