const regex = /<a.*?\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?\\\/a>', 'g')
const str = `<a href="www.something.com">Link</a>
words before <a href="www.something.com">Link</a>
<a href="www.something.com">Link</a> words after
more than one link <a href="www.something.com">Link</a> words <a href="www.something.com">Link</a> jsahd
<a href="www.something.com">)(YSHUDAKSJKJD<></a><a href="www.something.com">Link</a><a href="www.something.com">Link</a> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}