#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)ABC(?<Name>.+?)XYZ"
Local $sString = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"
Local $sSubst = "\g<Name>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)