package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ABC(?<Name>.+?)XYZ`)
var str = `ABCDEFGHIJKLMNOPQRSTUVWXYZ`
var substitution = "\g<Name>"
fmt.Println(re.ReplaceAllString(str, substitution))
}