using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABC(?<Name>.+?)XYZ";
string substitution = @"\g<Name>";
string input = @"ABCDEFGHIJKLMNOPQRSTUVWXYZ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}