use strict;
my $str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ';
my $regex = qr/ABC(?<Name>.+?)XYZ/mp;
my $subst = '\\g<Name>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";