re = /ABC(?<Name>.+?)XYZ/m
str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ'
subst = '\\g<Name>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result