import Foundation
let pattern = #"ABC(?<Name>.+?)XYZ"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ABCDEFGHIJKLMNOPQRSTUVWXYZ"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<Name>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)