const regex = /ABC(?<Name>.+?)XYZ/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ABC(?<Name>.+?)XYZ', 'gm')
const str = `ABCDEFGHIJKLMNOPQRSTUVWXYZ`;
const subst = `\g<Name>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);