# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\R\[)/\n/gm;t' <<< "[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3"