const regex = /(?=\R\[)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\R\\[)', 'gm')
const str = `[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);