using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\R\[)";
string substitution = @"\n";
string input = @"[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}