$re = '/(?=\R\[)/m';
$str = '[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;